Openclipboard Failed Exception


#1

Hi, I am getting this Openclipboard Failed Exception whenever i try to copy something in UiPath, be it an activity, a variable value or anything else. I tried re-starting UiPath as well as the computer but nothing works. Copying to clipboard is working fine for all other applications. Please suggest.
Screenshot attached.


#2

Does this happen all the time or only sometimes?
It seems a security related issue. Somehow UiPath does not have access to clipboard.

See: https://answers.microsoft.com/en-us/windows/forum/windows_vista-desktop/disable-copy-or-cut-and-paste-completely/125d5548-3c33-4157-9dfe-8933b85cc031

Adrian.


#3

Hi Adrian, this is happening every time. One thing I have noticed is that Cut-Paste is working fine. For example, if I want to clone an activity from position A to B, I do Ctrl+X at A and then Ctrl+V twice, once at B and then again at A.

Edit: I think it has something to do with .NET framework. I am having version 4.6.2. Can others please confirm their version?

Edit_2: Tried using 4.6.1. It worked once. Now again facing the same problem. Some urgent help will be highly appreciated.


#4

hi tarunch23

some questions first, to properly understand your test environment, as this is an issue that only you are facing

  • are you signed in as administrator on the machine? have you tried starting Studio with right click + “Run as Administrator” ?
  • do you have more than one Studio opened at the same time? Do you use Pro version or Community Edition?
  • what OS version are you using, is it up to date with all the updates? Is it a virtual machine?
  • is your Studio version up to date?

thank you very much


#5

Hi Gabriel,

The issue has been resolved. I was working on a PC with UiPath installed, using VNC viewer. So, my PC and the UiPath PC were sharing the same clipboard which was apparently locked by some application on my PC. I disabled clipboard sharing on VNC Viewer and it is working fine now.

Thanks,