Open Edge not working when process starting from Orchestrator to an unattended robot

Hello guys, I am having a robotic enterprise framework where one of the first step is to open Edge.
If I run the process attended from the studio everything is ok, but if I start it via Orchestrator, Microsoft Edge fails to open and the process is stopped.
I tried with both “Start Process” and “Open Browser” activities but without success.
Anyone had this problem? Do you have any idea why it doesn’t work? Thank you!

Hi! may i know what kind of error you are getting.

before using that use kill process activity and mention process name as “Edge”.


Hello @THIRU_NANI I am already doing the kill process activity to end any Edge instances.
And the error is from the next activity “Attach Window ‘msedge.exe Intranet’: No open windows found for ‘msedge.exe’. Please check if the application is running.”

Try with attach browser!


It could be timinig. If your unattended setting is somewhat similair to ours, your unattended execution involves setting up a windows desktop session, then running the script.

So consider it like windows loading an you try to execute all kinds of programs before you’re logged in… won’t work.

We updated our REF with an initial ‘find element’ on the windows taskbar-start button. (With a decent timeout). This solved our problem.

Also: instead of starting edge the way you do, using the ‘open browser’ activity does the same, and it gives you the container for follow-up activities in the same pass. This makes it a bit less volatile towards the path of the executable.