Open Browser Error - Help!

Hello,

I keep getting this error with when trying to open a browser in my process.

System exception.Retrieving the COM class factory for component with CLSID {EA5E2583-0D30-48BE-9EDB-47B2235ACD10} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)). at Source: Open Browser

I have since removed and reinstalled Uipath on my VM and also tried with multiple browsers. Does anyone know how to resolve this before I go insane

Hello @Bob2 :wave:

Check this link:

Cheers,
Rahul

Hey - I have read through that forum multiple times and tried everything that they are suggesting. Still facing the issue

Hi, Even I am also getting the same error, I uninstalled and re-installed the Uipath, still I am getting the same issue, note sure what to do, any help is appreciated, Thanks,
here is the error message,
" Open Browser: Retrieving the COM class factory for component with CLSID {EA5E2583-0D30-48BE-9EDB-47B2235ACD10} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)). "

Hi @Bob2

What is your version of Studio and the UIAutomation package?

Does upgrading to the latest versions of both helps you solve the issue?

Hi Macqiej Kuzmicz,
Thanks for your suggestion, the below issue got resolved after I updated UIAutomation Package with latest version, Studio was already with latest version.
Issue: " Open Browser: Retrieving the COM class factory for component with CLSID {EA5E2583-0D30-48BE-9EDB-47B2235ACD10} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)). "

1 Like