Open browser issue when used in a workflow and invoked

I have an issue in open browser activity.When i run a workflow (login module for an application which has open browser activity),it works fine but when i invoke this workflow under two other workflows and run the whole thing it throws an errror at open browser activity. Error:Open Browser: Retrieving the COM class factory for component with CLSID {EA5E2583-0D30-48BE-9EDB-47B2235ACD10} failed due to the following error: 8007007f The specified procedure could not be found. (Exception from HRESULT: 0x8007007F).One of the two workflows above this workflow has a database connection where I’m pulling a report but nothing is being passed into this login workflow.

I already tried the following:
-Reinstalled studio
-reinstalled uiautomation and systemactivities packages

Is it possible to share the workflow so others can investigate and try to help?

Hi @Lakshmi_C

Welcome back!!

Try to invoke the same workflow in another place and see whether it helps. As a test you can try invoking the workflow at the very beginning to see whether the open browser works there. It will help you to root cause the problem if it is caused due to some variable or something else that is used in it.

Hi @Lahiru.Fernando

I already tried that. If it is the first workflow then it is running without any issue. If it is invoked below two other workflows then this error occurs.