Open browser - cannot communicate with browser

Hi

I’m trying to run my robot on a Windows 10 machine, it worked fine on Windows 7, but now when it tries to open a browser, I get:

18.3.1+Branch.master.Sha.4c05f670b311e90ee097c589605b399e9bee4874

Source: Launch & log-in to SM9

Message: Cannot communicate with the browser, please check the UiPath extension.

Exception Type: UiPath.Core.BrowserOperationException

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
UiPath.Core.BrowserOperationException: Cannot communicate with the browser, please check the UiPath extension. ----> System.Runtime.InteropServices.COMException: Cannot communicate with the browser, please check the UiPath extension.
at UiPath.UiBrowserClass.Open(String bstrURL, UiBrowserFlags flag)
at UiPath.Core.Browser.Open(String url, Boolean privateSession, Boolean headlessSession, Boolean defaultSession)
— End of inner ExceptionDetail stack trace —
at UiPath.Executor.WorkflowRunner.EndExecute(IAsyncResult result)
at UiPath.Core.Activities.InvokeWorkflowFile.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

I have searched around this topic; suggested solutions were adding the site to trusted sites, allowing active scripting in the security settings, and running regsvr32.exe oleacc.dll as admin, all of which I have done to no avail…

hello ,

I think extension is missing out.

Please refer the below url page to add the entensions and try out.

Thanks

  • Remove the old extension.
  • UiPath-> Start -> Tools -> Chrome Extension.
  • Goto Extensions -> Enable Chrome Entension.

Thanks,

I went to UiPath->Start->Tools & clicked to download the Chrome Extension, then opened Chrome & clicked Enable Extension on the pop-up.

That appears to have sorted it, thankyou both :slight_smile:

1 Like

hello @alasdhair

Please mark it as solution for future uses :slight_smile: