Open Application activity when used to open a PDF file fails

pdf
activities

#1

When I use the Open Application activity to open a PDF file using Adobe Acrobat reader DC, it only opens the application and does not open the filename specified in arguments from the folder path specified in the working directory. It works for the other applications I tried with, only with pdf using Adobe, it fails.


#2

I couldn’t get it working either when checking some time ago.
Quick re-googling only showed that others had problems with it as well - not only with a robot but in general.

As a workaround, assuming AcrobatReader is the default app to open PDF on that machine, I’d suggest using StartProcess activity and then AttachWindow - you need to provide the selector anyway in OpenApplication so it’s not much of a difference.
Note - if you provide the path to the file, it will be opened in default associated program essentially the same way as you’d open it from folder by user.

Regards.


#3

I have indeed used the same workaround. Yes, Acrobat is the default app to open PDF.
Thanks for your input, Andrzej. Really appreciate it!


#4

@andrzej.kniola @Amrita_Mogali: Somehow it works fine for me though I am not sure if we are working on different versions of UIPath. I have tried opening different pdf files. Following are the parameters added in “open application” activity:

  1. Indicated element on screen (selected pdf file opened on machine)
  2. It automatically added selector (from which I removed the title of pdf) and FileName
  3. In Argument, I defined the document path along with document name

Hope it helps!


#5

i got an errror, ‘AcroRd32.exe Doc3.pdf’ : Selector not found when i tryed to use StartProcess


#6

Hallo igul!
i try it too with your instruction, it worked. Thank you for your instruction.