On premise Orchestrator manual download packages issue

Hi All,

am having issue where by users (with UiPath assistant) are not able to pull packages from on-premise orchestrator, its demanding going to internet to the below links.

Their computer are restricted to have internet, so how can i have all the packages on our on-premise orchestrator so as they can’t go to internet

Hi @Kelvin_Chelenje - sorry, I don’t really understand your question. Do you need to have ‘all’ versions of all UiPath packages in Orchestrator?


no, the server with UiPath assistant and server with orchestrator on-premise have no internet. so when user with UiPath assistant install an new bot pulls requiered packeges from orchestrator machine.

then for the missing packages it forces to go to internet.

for this reason/scenario, i wanted to see ways to manual download and import all requiered packages in on prem orchestrator without internet

That’s normal, it’s how it works. By the way, it’s not the Orchestrator server that downloads them, it’s the robots.

You should talk to your IT team about allowing downloads from UiPath.

The only other option is to download the packages manually then upload them as libraries into Orchestrator.

i have uploaded all the packages under project.json but seem there’are other missing packages as i see its going to internet to request something

how do i know those missing packages?

If you have Studio installed on the server, open the project in Studio and see which packages are missing.

all packages are found once i use studio…my consern is when i open assistant it demand downloading and install packages…so it seems to go to internet instead of on premise orchestrator

and it doesnt show which package is the one tries to find on internet so i can download it manually

Hi @Kelvin_Chelenje
are you using same version of UiPath studio and assistant.

Upon reviewing your problem in forum , most of the time this issue occurred due to version compatibility.

Hope its helps!!!

Open Studio on that machine. Click Manage Packages. Click Settings. Make sure there is an Orchestrator Host entry in the “Default package sources” box, and that it is the correct URL.

Please navigate to this folder. Then, maybe make a safety copy of everything inside. Then delete everything (except the safety copy). Then open your project in the studio. Then check the folder again. All the necessary packages & subdependencies will be there then. These are the ones you need to provide in the end.



Is the studio machine having internet?

And in manage packages do you have only orchestrator host?


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.