Odata Add queue item request URI not found

I am trying to add queue items through api call. But submitting post, getting error “No HTTP resource was found that matches the request URI 'https://cloud.uipath.com/odata/Queues/UiPathODataSvc.AddQueueItem” both in postman and direct url access on browser.
Please help me resolving this issue.
Note: even tried with https://platform.uipath.com/odata/Queues/UiPathODataSvc.AddQueueItem

1 Like

Hi @Madhavi

You will need to follow this bit from our documentation:

Mainly, your URL needs to follow this scheme:

https://platform.uipath.com/[Account Logical Name]/[Tenant Logical Name]/odata/Settings/UiPath.Server.Configuration.OData.GetLicense

@loginerror Thank you for the response. I have followed the same steps as mentioned and the GetLicense api that you specified still works as expected. The issue I am facing is on AddQueueItrem API. Tried both specifying [Account Logical Name]/[Tenant Logical Name] and not specifying on the API url. Below is the error-

Also, tried accessing the APIs directly on the browser. Still found issues on AddQueueItem API url.

HI @Madhavi - I think, in screenshot 1, you are missing the headers.

“testQueue” is Queue Name
And I always make a mistake with the highlighted type, where I have selected json and it should be json only.

Body :
“itemData”: {
“Name”: “testQueue”,
“Priority”: “High”,
“SpecificContent”: {“Name”: “Mahesh”},
“DeferDate”: “2020-05-21T06:34:38.867Z”,
“DueDate”: “2020-05-21T06:34:38.867Z”,
“RiskSlaDate”: “2020-05-21T06:34:38.867Z”,
“Reference”: “string”,
“Progress”: “string”