Unable to add items to Queue using REST API Call

Hi Team,
We are unable to add items to Queue using REST API Call and it gives us the below error .

queueItemParameters must not be null

Could you please assist in getting this resolved? The same works for other users.


  • Abhilash
1 Like

Any updates/ideas from anyone on what may have caused this to happen?

  • Abhilash

Had the same error. Turns out I was setting a parameter to an invalid value. I was trying to set a queue item’s priority to “Medium” but the option allowed for the equivalent meaning was “Normal”. Once I changed the API call to pass “Normal” as the priority value, the request went through.

I fixed it. There was a folder id which needs to be passed as Organization Unit ID. In cloud orchestrators, unlike legacy platform orchestrators, the folder id was just one id whereas in the cloud model , u have default and shared folders, making the api to fail if you dont specify folder. I got the folder id for the orchestrator and was able to fix the issue.

  • Abhilash

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.