OCR doesn't work with IBM AS400

Hello Guys!! Good afternoon!

I’m trying to SCAN the AS400 with the OCR but I’m receiving a bad output like this one:

image
output with tesseract OCR

I’ve tried to scrape text in all mods.
Like Full text, Native, UiPath Screen OCR but no joy… It almost worked with tesseract OCR

image

The idea is, pull that data, insert it into a list string, and split each variable with a Foreach loop alongside with some string manipulations.

I can do it with Anchor base activity and get each element 1 by 1, but I would like to put the data in a list and iterate over it.

Anyone with ideas? Thank you

Hi,

If you want to interact with AS400, the best is to use UiPath.Terminal.Activities. Please check https://www.uipath.com/kb-articles/automating-terminals-and-mainframes . Then, it will be easier for you to scrape the screen :slight_smile:

Good luck!

There is option for extracting data from Mainframe using UiPath.Terminal.Activity

Check that

Regards,
Nived N

Hello!! Thank you a lot for your time. I will try it tomorrow.

If it works well i’ll came here to validate your awnser as correct.

Thank you my dear.

1 Like

Hi,

You’re welcome! Do not hesitate if you have any issue with the connection/interaction.

Best regards,

1 Like

Is working perfectly,

Thank you a lot :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.