Object reference not set to an instance of an object web activity

Hi occuring some strange events… I am using web activitys to perform a series of actions corresponding with an api. This works PERFECT with debugg run. as soon as i run the robot in “full speed” just run it. it throws me an error on the response after i perform a post where it says Object reference not set to an instance of an object. Why is it different happenings based on the runs ?

Hey @langsem,

This exception normally occurs when a variable hasn’t been initialised (given a value). What variable type is your variable?

Try using an Assign before the activity that breaks like this:

MyVar = ""


Can you share us whats the value you are trying?


now i got Deserialize json: unable to cast object of type “Newtonsoft.json.linq.jvalue” to type “Newtonsoft.json.linq.jobject”


Can you share the screenshot and data screenshot?


It just seems that the robot cant handle normal run. That it just runs to fast for itself and cant pick up the data before it moves to next activity


Put a delay in behind the activity that gives the variable its value.

how much does it need tho? tried with 2sec


If 2 seconds doesn’t work, go up to 5 seconds. Then 8 seconds after that. If either of those times don’t work, consider splitting the activities up with a different activity.

it kind of loses its effect tho, the purpose its to make it faster than a human, but if i am supposed to push it on delay it will become slower

I understand that. Have you tried splitting the activities up? Are the activities directly next to eachother, and if they are, do they need to be?

they are in different workflows and yes they has to be relative close