Not able to use select item in oracle java application (Drop down)

Team need help,
how to select a country in a drop down that matches my excel data,

  1. i’ve tried using select item
  2. if i use hotkeys ,code will be lengthy

You can directly pass the value from excel to the select item right?

I mean, loop through the values and pass the value to select item activity as string

@Pradeep_Shiv
Please confirm following:

  • JAVA Extensions are installed?
  • Select Item is recognizing the Drop Down Box? (the select values are offered on the activity)

Maybe you can give some more details on the failure:

  • value selection result within the run / debug mode / debug mode with breakpoint and waiting before select item?
  • a screenshot from the drop down

Thanks

yes! i can but it’s not working

Some applications need a click activity on the drop down before the select Item activity, can you try passing another click activity on the drop down before the select item @Pradeep_Shiv

ths is the selector i’ve to choose “WE” here

tried @HareeshMR

Perfect. On the first look it looks ok
I agree to @HareeshMR a click before and for RnD Purpose a before delay of 5000ms on the select item let you find out if e.g. the application is responding just a little bit slow.

At our end we solved often such issues with find children

Also have look on here

1 Like


this what my drop down looks like
1)can’t use type into
2) and its window’s application

Is it working with another clicks or any other image recognision @Pradeep_Shiv?

Please check and let me know once :slight_smile:

i tried every other method , this is the last part of my project if i get this done
and it’s almost done!
im trying from few days it’s not working out


i tried this but same error

Heyy it is javafx33 issue, we have fx issues with the java versions. Can you try to update the java and check once ?

ive downloaded from oracle! is there any other updates available??

@Pradeep_Shiv
At one point it confuses me the selector shown with the WE select item differs from the combo box with the countries. Did I missunderstood some things?

However a quick checker test on reaction of a combobox is following:

  • us a type into / later can use with send hot key
  • configure the selector to Angola
  • let type into / send a key down on it

If the Box now get selected you have found the first of mabye more option on how to interact with the combo box.

I am telling this because of: In a session with a forum user there was 1 of 4 combo boxes totally not reacting. So we tried out 7 methods to get the proof that box can be interacted. The described option from above was the winner

no,im just saying i’ve many drop downs in this application,if in case you guys may suggest hot keys! so

  1. Type into is not working .

it’s the Java Fx issue it’seems as @HareeshMR told ive gone through some other topics,can you tell me how to resolve it!

Thank you!

Ok thanks fo clearification, Now understood that you have to deal with many comboxes and no one works as expected

exactly!

Did FIND CHILDREN activity help us in this

Cheers @Pradeep_Shiv

ive created a workflow,and i can select specific “aaname”