Not able to connect with SauceLabs in MDM

Dear Forum members,

I am working on a mobile automation projet. And i want to host my .apk file to SauceLabs and connect to mdm. Is there any documentation to configure the SauceLabs in mdm, so that i can follow that.

Please suggest how to connect with MDM using SauceLabs.

Thanks

The relevant documentation is at Mobile App Testing | Sauce Labs Documentation. This tells you all the things you need to know on how emulators/devices and appium are running. For the MDM you have to read the relevant documentation.

I’ll provide an example and I hope this will help you get started:

  1. This is the SauceLabs Appium address. This address is provided in Account → Settings → Driver Creation (Sauce Labs). I’m using a variable but the address is of the form https://user:secret@ondemand.eu-central-1.saucelabs.com:443/wd/hub
  2. Platform (iOS/Android)
  3. The name of the device or emulator (please see Using Real and Virtual Mobile Devices for Testing | Sauce Labs Documentation)
  4. The platform version (see supported devices and also Platform configurator | Sauce Labs)
  5. By default Sauce uses the latest version of Appium but there are instances where you want to force a Appium version (eg. we don’t work on 1.20.x). The Appium version is correlated with the Platform version, so use the ~Platform configurator~ to see what Appium version goes with which Platform version.

For how to upload an application, please see Mobile Application Storage | Sauce Labs Documentation

Hope this helps!

@phaserescu Thanks for the reply.

I am trying with all configuration and with the app https://uipathtestappsto.blob.core.windows.net/testapps/TheApp.apk
But when i am running the device in mdm then i am getting error like
Error: Infrastructure Error – The Sauce VMs failed to start the browser or device. For more info, please check Common Error Messages - The Sauce Labs Cookbook - Sauce Labs Documentation Wiki

Thanks

It’s probably from the Appium version 1.20.x (there is a bug in Appium 1.20.x). See in my reply on how to change the Appium version.

@phaserescu

I am passing these parameters in mdm and didn’t passing any Appium version but still device is not launching in mdm and if i am passing the appium version then also getting same error.

WhatsApp Image 2021-06-22 at 3.56.55 PM

Thanks

I just tried to connect using your settings but using Appium version 1.17.1 and it works for me.

From the Platform configurator, the supported versions of Appium non 1.20.x, for Platform version 11.0 are: 1.19.2, 1.18.1, 1.17.1, 1.16.0 and 1.15.0.

Also please redact your Driver Creation url as it can be used by others as well.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.