No proper way of sending HTTP requests through proxy with authentication

Hello,

I have noticed multiple topics with the same issue.

There is no proper way of tunneling HTTP request activity through a proxy. I’ve tried configuring robot.exe.config, studio.exe.config to no avail. My machine is behind a corporate proxy and i can’t send HTTP requests to outside world.

Any tips?

2 Likes

Upping this issue because i still need to tunnel specific HTTP requests through proxy.

In terms of allowing robot service to use proxy, you need to edit the config file. On 19.10.x version robot service relies on proxy configuration in UiPath.Executor.exe.config

Please refer to:

I’ve managed to route robot’s external http requests through proxy that requires authentication by adding additional attribute defaultProxy useDefaultCredentials=“true” /> My proxy requires authentication but allows authentication based on currently logged user.

This does not afect the Studio itself (only works when you start robot and the service executor is sending a request) so http wizard in studio may not work properly.

1 Like

Thank you, I’ve already configured the Proxy-Authorization header, but it’s good to know that other options are available. Much appreciated.

Thanks for the link!