How to get through a proxy with Http request activity

Hey guys,

I am working for a client and I realized when importing my code (that works perfectly fine on my end) on client’s infrastructure that Http request activities (from Web package) would return null values. By debugging I found that the error captured was something like “407, proxy authentication error”.

What is odd is that the similar request made manually through an open browser would actually work.

Now I have tried to follow the steps in this official link, but as you can imagine, most of parameters here are blocked by security.
Since browsers also worked, I tried the headers techniques, but again, doesn’t seem to solve the issue.

We checked with IT Security and saw in the proxy log that when UiPath emits Http requests, they actually do not use authentication and that is why the proxy block them. By adding a rule of no-authentication to the destination API we managed to solve the issue eventually, but I feel like it should be a better/cleaner method to do this (especially since this workaround require many business authorizations).

Last thing: on the parameters of the Http activity we can see there’s a section about “Simple Authentication” :
This doesn’t work either (maybe it’s only for gateways).

Is there a method to solve this issue directly into UiPath ?


you solve it ? i have the same problem could you help me ?

Did you solve it?
I am facing same issue, getting proxy authorization error.

Proxy-Authorization header seems the only way, but we need to get the credentials and do the base64 encoding first.

I couldn’t solve it from UiPath as the activity doesn’t allow to go through proxies (we tried everything).

We had to add an exception in the proxy from the specific VM to access the specific API online. Security was not happy but we had no choice.
Really hoping UiPath makes thing easier with this activity in the future.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.