No items are adding to my orchestartor queue

see i just have a simple, where I’m reading an excel fie, using a read range and passing that through a for each row

then using “add to queue” activity

then I’m passing the name e.g “DemoQueue” (The same queue is there on my orchestrator)

I’m properly filling the item details collection area
but then I run that workflow, it runs smoothly but

there are no data been uploaded to my queue?

please let me know :slight_smile:


Check if you enable the unique reference
Also can you share the screenshot how your queue looks like
Check that you connected to orchestrator



Sometimes it is not visible in queues directly with remaining count
Click on VIEW TRANSACTION of that queue and if there are queue items in it that would be fine


If it still not appearing
—make sure queue name is correct
—and also check whether any data is obtained first and it is uploaded to queue
To check with the data first use a WRITELINE activity before add queue item so that we can validate the value in output panel whether there is value or not
Sometimes there might be the case where Input data is missing

Cheers @Jiban_Kumar_Das

check once , unique reference

Try with No option

It takes time before the main Queues page updates. Go directly into the queue and see if there are any items.

Also, if you’re reading a range into a datatable and then adding multiple queue items, you should use Bulk Add Queue Items. It’s much more reliable.

Are you sure your Studio is connected to the same Orchestrator (including tenant and folder if you’re upgraded) you’re logging into through the browser?

Hi @Jiban_Kumar_Das,

Can you please share screenshot of properties of your add queue item activity?

And also the queue section from orchestrator?

There can be a mismatch in the queue names(any additional spaces entered?)