Need to make a selector dynamic that already has ***ALL USERS*** the asterisks in it

I’m trying to make my selector dynamic, so that if there is a software update, and the version number changes, I want that to be replaced by the asterisks * But what I’m trying to select also already has a bunch of asterisks in it. So I haven’t been able to click on it in my work flow.

I’ve tried click, double click, Anchor to find multiple elements and then double click, I tried find OCR text,
I tried click text, and I’m guessing that if none of these work, it might have something to do with my selector. Here it is. How do you think the additional Asterisks that were already there are affecting it? I’ve also tried to delete them all and replace them with only one asterisk on each side. How many Asterisks can you have in a selector? Is there a limit? How does that affect a selector?

<java name='EX PRO Instance, EX 11.7.0 *** ALL USERS ***' role='label' />

I have it in an attached window. Sometimes, the selectors work, but not all the time. I needs something reliable that clicks on it every time. It’s a selection from a list of two different versions of the application. One is for training purposes, and this selector clicks on the one for all users to log in to the application. Once it’s selected, the submit button is enabled to click on.

Without clicking on one of the versions, the submit button to launch the app is disabled.

One * or more than one * doesn’t make any changes, it’s just 0 or more occurrence that’s it, this issue is might be in your target container there might be more than one element having these attributes in selector. And hence you are not able to click anything

1 Like

Fine-tune your selector(take full selector) then try click, if that works then try to chage property one by one but make sure your target elements contains atleast one unique selector property in it

1 Like