My UiPath Assistant doesn't show the robot even though it's "Connected, Licensed"

My UiPath Assistant is already connected to the Orchestrator URL and Machine Key so it says ‘Connected, Licensed’. However, on the Home Assistant display, the robot does not appear and seems to be in the process of loading, this process takes a long time and there are no results. I have tried to close and reopen my UiPath Assistant but the result is still the same. I also tried to reinstall the app but the result is the same. Can anyone figure out the problem?


Welcome to our UiPath community.

Hope below thread helps you.

Can I implement this in Unattended Robot?

Hi @Burhan_Maulana

Could you make sure that your robot is added to the right environment?

yes, I’ve set all components to match, I’m using Service Mode because my robot is Unattended. But the robot still doesn’t appear on Home, and if I disconnect and then reconnect, the home page will load again without displaying the robot.


Could you please mention your Studio version and orchestrator version?


when I checked the log in File Path UiPath\log\combined, I found an error that might occur in the PC connection with the orchestrator, can anyone help?

this is a log message:

{"message":{"identifier":"IpcServer:route:error","msg":"Error received on route: '/robot/getServiceUrl'.","type":0,"err":{"endpoint":"ISettingsOperations","methodName":"GetServiceUrl","name":"System.IO.IOException","message":"ISettingsOperations.GetServiceUrl threw System.IO.IOException: \"Could not connect to UiPath Robot Service. Make sure the service is started!\".","stack":"System.IO.IOException: ISettingsOperations.GetServiceUrl threw System.IO.IOException: \"Could not connect to UiPath Robot Service. Make sure the service is started!\".
    at Function.createRemoteError (C:\\Program Files\\UiPath\\Studio\\UiPathAssistant\\resources\\app.asar\\main.js:103:338579)
    at Function.fromRpcResponse (C:\\Program Files\\UiPath\\Studio\\UiPathAssistant\\resources\\app.asar\\main.js:103:338260)
    at a.<anonymous> (C:\\Program Files\\UiPath\\Studio\\UiPathAssistant\\resources\\app.asar\\main.js:90:103558)
    at (<anonymous>)
    at s (C:\\Program Files\\UiPath\\Studio\\UiPathAssistant\\resources\\app.asar\\main.js:90:101863)
    at processTicksAndRejections (internal/process/task_queues.js:97:5)"}},"level":"error","timestamp":"2022-01-13T01:53:21.534Z"}


Have a view on this


@Burhan_Maulana Re-Publish your code and re-connect the connection with uipath robot.

@Burhan_Maulana Maintain the stable internet connection.

Please open your Service Console
Start > Type Services > Open

Scroll down in the list and find your UiPath Robot Service, ensure that it shows running, if not Start/Restart the service, wait until it shows running and check UiPath Assistant again.


It would be odd if your Assistant shows Connected, Licensed if it is giving you communication errors about the service. I would also confirm you do not have multiple UiPath installations, having an install in User Mode (User’s App Directory) and one in Service Mode (Program Files) could cause conflicts if you are not opening the right instance.

Please see the following documentation for additional solutions for “No Connection to the Robot Service”, there are 3 for this specific error.

@Burhan_Maulana Maintain the stable internet connection.