ML Skills are not Deploying

Good Morning!

I’m trying to use Document Understanding to extract data from invoices, but I need to train a new model.

I’ve labeled the documents in data manager, exported it to a dataset end trained my pipeline. Although I had a successful return of the pipeline training using my dataset and the purchase order ML package, the ML Skill Deployment always fails.

I had success in the first two deployments, but after these all the others fails.

Hi @Samuel_Simao

What is the error you are getting?


Hi @suraj.setty

When I try deploying an ML Skills, it stays with Deploying status for 2h and then goes to failed.

This is the error reported by Logs:

Hi @Samuel_Simao

Please check If you have enough license.


Before the actual error you should see some warning can you check ML Logs for those warnings?
On top of that if you click on the ML Skill on ML Skill page and then check streaming logs can you show us the logs?

Also if you are trying to deploy a model after retraining then make sure you select minor version different than 0.

Yes, I think I do have enough License.

I thought it could be allowed just one ML Skill at a time, but even with no ML Skill deployed it continues not working.

Hi @Jeremy_Tederry

this is the last warn message in my logs:

I will try it again, thanks for the advice!

May i Know what is the status of “ML Package”, if its undeployed.

Please try creating the ML Package and ML Skill Together (One after Other) and check the Status,
The ML Package should be Deployed and ML Skill as available.


I just tried this: Deleted all ML Skills and ML Packages of my project. Then I had created a ML Package of Purchase Orders and right after I created the ML Skill with this package.

This was Done at 9:46AM, and I have already received in the logs 3 warn messages like this one:

I really don’t understand. In the first project that I’ve created this process has worked, but now it isn’t anymore.

Let me check that from our side. Are you trying to deploy with or without GPU (just to understand better the issue, it should work anyway)?

I just tried on my side and this worked on CPU. Can you give it another try if you used CPU?

I have used GPU. I will try again without it now.

I deployed the ML skills without GPU and it worked. 3 ML Skiils available to use.
I don’t exactly the reason for this issue, but in fact deploying with GPU was not working and with CPU the ML Skill is deployed.

Thank you @suraj.setty and @Jeremy_Tederry for your help!!