Milestone 1 - Working with Decisions, Iterations and Scenarios

Let’s talk a little bit about more complex tasks where decisions, iterations, and scenarios are needed.

In your own context, how can you see them used? And now that you learned about making your robot take decisions, go through iterations and work in scenarios, do you find RPA more valuable?

For any technical question or to provide ‌feedback, please create a new topic in our Reboot Your Skill category here.


It seems the link to download the zip which contains the material for this practice is wrong.

You can copy them from the solution though! :slight_smile:

Have a nice week!


Hi! Echoing andres, the zip file is the same as Week 1 practice.


Hi @loginerror , @cosminSimion ,

Good Day.

Please have a look, it seems that the zip files contains Week 1 working documents.
These are the files we got :

Although we are getting correct files and folders in Solution zip


1 Like

Dear all,

After going through the exercise and run the automation I got errors like the one below

Tried to run the solution provide but I still get the same. Any suggestions ?


1 Like

Yes, i also got the same files @Nidhi_Chaturvedi

1 Like

Although I was not able to run the project solution, I was able to complete the exercise by downloading the solution, and copying the four items into my projects directory.


On my computer, my project directory is C:\Documents\UiPath\ModifyWordTemplates

1 Like

Is those two answers exclude themselves?

For me, they shoudn’t be both true…

1 Like

@loginerror I have a question about dependencies used in solution (i had use this solution project, because files for exercise wasn’t there, where them should be :wink: ).

Why there is prerelease packages in solution showed to participant of this course. I assume that quite a lot of people start this journey and knowledge about project packages could be quite minimal.

When I opened project with solution I get internal error all the time. I switch profile to Studio, then repair dependecies (some of them get better but Studio has freezed during this action - I had to kill it in Task Manager). After that operation I was able to open project is StudioX profile and solution project worked as predicted.

And still, one of the packages is not available to upgrade in any feed:

Information about this package in Studio:

I’ve got those package feeds:

My Studio is 20.10.6

So I have two conclusion:

Please deliver solutions only with stable version of packages. I assume that learning plan should help people learn on examples without making their learning path harder :wink:

Second one - probably profile of StudioX need to be checked in case of working with projects, where dependecies has problem to download/install. Studio profile is better in managing those situations.


I got this same error. I even tried renaming the alt-text, yet I still got this same error

1 Like

Hello @Marios_Kontopyrgos and @demmybite ,

Could you please try adding a delay activity before the Replace Picture activity ?
The Delay activity looks like this and you can mention the delay in seconds.



1 Like

still didn’t work for me. It’s clearly stating that it couldn’t find the alt-text I used

1 Like

I also had the same problem. I deleted any files that were created in edited resumes and re ran the bot and it worked fine 2nd time round.

1 Like

Thanks for pointing it out. The easy fix is to change the version of the package in the project.json before opening the project, but we will fix it of course :slight_smile:

1 Like

The question in the scenarios section was a bit weird, the one around the Ifs.
The option “I’m not sure, there are a lot of If activities there.” did not apply to me, still not answering it with “Yes” made the whole answer incorrect. Minor thing, but I’m basically told to be confused :smiley:

Other than that, the zip file contained a bunch of hidden objects (files, folders) which, while being interesting, can be ignored, but their existence confused me more than the nested Ifs ^^

1 Like

i got the same problem, even i check the solution and i had the same, i dont know what’s going wrong

1 Like

I also had a hard time getting everything to work, I am spending to much time on each one and I have to finish each week during the week

1 Like

Agree. I definitely know what it’s doing even with all those Ifs within Ifs, so I’m not “not sure”.

1 Like

To create the Scenarios-Switch exercise, the process proposed in the solution does not coincide with the solution I gave it.
In my case, we first check if the cell is empty: If yes, then I use the Switch to complete it. I used 1 IF and 1 Switch.
In the UiPath solution, it first uses the Switch and then for each of the possible answers, it uses 1 IF to check if the cell is empty. In other words, it uses 1 Switch and 3 IFs :no_good_woman:

1 Like

I have tried this solution but still dint work for me.
I think it’s because the contents of the file doesn’t get copied in the first place.
Can someone please help

1 Like