Microsoft OCR scrap giving different output issue

HI friends.

Microsoft Ocr does not read exact text…

image

Row 1: it has removed ","after 5 = 365,9
Row 2: it replace comma “,” to punctuation = 253,82
Row 3: it has removed comma and have added empty space = 6295,9
Row 4: it couldt read comma = 2764,32
And if the scrap value is 0 the its not reading that 0.

Now here is the result, it has read correctly …
image
Help me… that how can i be sure that it has read the correct value… and i need the correct value.

I have tried with Google Ocr also but it’s worse result, also tried wih low or high scale. Same with Microsoft.

kindly help

Hey,

So just to get one thing straight, per my experience, the most accurate OCR is ABBYY Flexy capture, and that one needs to be payed. It is payed per request and even so… it is 99% accurate, and that means… your comma can be lost, 1 can be 7 or vice versa, etc etc

The best way, if you need exact value is to try to get it with get text and selector, if it is possible.

Now, to do this with OCR…

Image that you provided was pretty ok, so OCR Google read it without problems

1 Like

Thanks @Radomir_Ivankovic

Due to security-- not allowed to use cloud or other OCR engine…
Google ocr is giving more bad result then Microsoft OCR… result which i shared…

So i need to know, how to solv this issue if it comes… more time…

Hello,

So I have used Tessaract, that one is Google but I dont think its cloud, Google Cloud is something else, can you test it with tessaract, and in properties make it to be Legacy.

Cheers,
Radomir

I did it…
here is result of Tessaract
image
of the same ID…
Tessaract is far better but problem is, some time it’s not reading right number…
Like reading 1 as 4. and if its 4 then its reading as 1. and writing that value as output. and some time it’s writing 3099,S6 where s is a 5…
So when i used Tessaract I felt its perfect as its putting comma right place and reading comma as no space… but when i analyzed it with the real data then i felt it’s not prefect…

So if i use Tessaract then i can not be sure that value 4541,61 is correct or its 1541,61… and oppesit also,

Huh, truth is that you can never be sure with OCR…
especially if that is money… so you ALWAYS need to have human to approve…

that is my experience so far…

It look like that with MS and Google there still need of a humen unless we can use Abby… which is not possible.

I thought maybe, there is another way to improve the result…

Per my knowledge, not. Even with ABBYY there is chance of reading false values.

But lets take step back, from where you are reading those values, is that picture, pdf, web page? what is the selector, I can see that is table, maybe there is another way of accessing there not to have OCR.

Cheers,
Radomir

1 Like

Its from a program but this program have security in front so i can direct click on column and can only use as a Image.

ctrl name=‘Udsogt’ role=‘grouping’ />
ctrl automationid=‘PART_FootersPanel’ />
ctrl idx=‘4’ role=‘client’ />

here is the selector…
idx is the row -column where those value appears…

well that is great!!

you can always use double click to select all and then copy to clipboard.

will that work?

Cheers,
Radomir

do not unerstood what you want to say… can you explain.
I tried but double click not working and not even ctrl+all to copy the selector

So, create good selector, dynamic one. and then you need to do triple click on it, when you do triple click it will select your text.

to do triple click, paste click single activity 3 times, and in properties DelayAfter and DelayBefore make 0

it will select text where selector is, and then use copy selected text activity and you have it.

Where are you putting this Copy tekst varibale in click?

Nowhere in click, you have copy selcted text activity bellow.

Cheers,
Radomir

But how this “copy selected text” activity know that it has to get the text out from those 3 Click activity?

Yes, it will copy whatever is selected, and with 3 clicks you will select text.

image

It’s giving error on “Copy sel text”

What is the error, can you paste it here?
Does that webpage allows copying?

as it’s ot a button so I do not think it will work.

Did you put delay before to 0 and delay after to 0 on click activities?