Microsoft OCR Engine

ocr
training

#1

where can i earn the Microsoft OCR Engine? I need it for again with my trining in UI Path.


#2

Hi,

Not sure what exactly your asking about Microsoft OCR Engine.
If this engine missing in your UiPath Studio version then please update it Version 2016.2.6274.33252.
But i assume you need more info on this OCR Engine.
Hope this might help you.
https://www.uipath.com/activities-guide/microsoft-ocr



#3

Thanks a lot.
My problem is where I arrive to the walkthrough where i have to use this tool,
the tool there isn’t in the place where it have to be:


#4

@Reben23 – You will not see Microsoft OCR under Setup extension. Please try screen scraping , to scrape text from a notepad. Once you do that, you can see that by default UIpath has used Microsoft OCR.


#5


#6

This is what i found:


#7

Can you please let me know what are you trying to scrape here?
Also, you can trying using Google OCR engine?


#8

This is an exercise form the training with UI Path. Consist in a citrix screen scraping with this application:


#9

Can you please tell me the Lesson and Exercise Number?


#10

Lesson 7 - Practice 1 Walkthrough


#11

@Reben23

Hi Ruben

I followed the exercise and i am able to execute everything without any issues. Can you please explain me which element you are trying to scrape?

Can you also try to change the OCR engine and try changing the scale as well?


#12

Finally I have finish the practice. All has gone ok, all but the first point of the exercise. I think that maybe is for the lack of the Microsoft OCR Engine, is related with the detector of text on the images.


#13

That’s Great Ruben. All the best for the rest of course.


#14

Thanks a lot for your help Gourav.


#15

Reading on the forum it said install Microsoft SharePoint Designer 2007.
Do a custom installation and select everything with OCR or just check everything. This worked for me.
I tried installing SharePoint Designer 2013 (latest version) first but that didn’t work.


#16

@Reben23, @snoopy, I was able to install MODI using the same method snoopy describes. But it doesn’t work for me. EDIT It works now, see the bottom of the post.
I have [EDIT - had ] the same issue as Reben23, with exactly the same error at exactly the same place in the same Walkthrough scraping the frmAnyTeller app.
(OCR method failed to scrape this UI Element). Google OCR scrapes it but poorly.
I have MODI installed, but that of course is 32-bit and my Win7 is 64-bit. My desktop fonts are scaled to 125%, but on a large HD screen I believe that is even the default.

I tried using Microsoft OCR from “Click Text” in the Citrix recording on other web pages as well, and it won’t recognize anything.

Edit: I tried on a Windows 10 machine. MODI installs fine on a 64-bit installation of Windows 10, by the way. But my results with it were so poor I could not accurately complete 7.1 and 7.2. Perhaps as a result of UiStudio not being able to find the image following saving and restarting, UiStudio brought my machine (16GB of RAM) to a standstill, and I had to do a hard reboot. Twice, as a matter of fact.

By the way, I am not complaining about a fine product, but I would I humbly suggest that relying on 32-bit software that is a) discontinued and c) ten years might not be good long-term plan.
:grinning:

If this is the worst thing that happens to me all day, I’m in great shape. Thanks again for everything.

Regards,
burque505

EDIT:
PROBLEM SOLVED.
In the hopes this will help those who install MODI from SharePointDesigner.exe, I’ll pass on what I needed to do.

  • First, I had made the mistake in Win7 64-bit of not rebooting after installing MODI. (SharePointDesigner.exe’s installation program didn’t tell me to, but I should know better by now. ) :grimacing: That hosed everything.
  • After reinstalling the first time, everything was still hosed - although I had Microsoft OCR available, it wouldn’t recognize a thing… (@Reben23, same problem as yours?) I then uninstalled by running SharePointDesigner.exe again. That gave the option to remove, which I did. That apparently cleared out whatever cruft was causing my problems.
  • But there was another problem with 7.2. I had to right click on ExpenseIt.exe and change the properties, as shown:
  • In my case, I have to use a television for a monitor (old eyes) at 1080p with fonts scaled to 125%. That throws off ExpenseIt.exe (and many other apps). By the way, I didn’t need to do that for AnyTeller.exe - although I tried it, it didn’t make any difference in the display size. Disabling display scaling on high DPI settings did the trick and I was able to finish both exercises completely. :beer:

I guess the moral of the story is keep on plugging.
Regards and good luck,
burque505


Error using Read PDF with OCR
#17

Hi,
I am trying to read pdf file.But Google ocr is unable to read pdf.
please do needful


#18

Hi there,

I would suggest that you use Abbyy cloud OCR fine reader. They have a free trial online. Just register and login to get the trial version and monitor your available pages from their site as well. let me know is you have questions.

Hope it helped.