Microsoft OCR doesn't work

ocr
studio

#1

I have installed Sharepoint Designer 2007 (MODI) and now I can see Microsoft OCR engine in Screen scaping tools. But when I run the robot it always return with error message. Below is the detail. My windows version is Windows 7 with UiPath community version 6522. Anyone has idea?

Source: Microsoft OCR

Message: Error performing OCR: MicrosoftInternalError

Exception Type: Exception

System.Exception: Error performing OCR: MicrosoftInternalError

Server stack trace:
at UiPath.Vision.VisionClient.ScrapeUsingHostService(OCRInput input, OCROptions options, CancellationToken cancelToken)
at UiPath.Vision.VisionClient.ScrapeImage(OCRInput input, OCROptions options, CancellationToken cancelToken, Boolean useHostProcess)
at UiPath.Vision.VisionClient.Scrape(OCRInput input, OCROptions options, CancellationToken cancelToken, Boolean useHostProcess)
at UiPath.Vision.UiImage.ScrapeOCR(OCROptions options, CancellationToken cancellationToken)
at UiPath.Core.Activities.OCREngineActivity.<>c__DisplayClass36_0.b__0()
at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs)
at System.Runtime.Remoting.Messaging.StackBuilderSink.AsyncProcessMessage(IMessage msg, IMessageSink replySink)

Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.EndInvokeHelper(Message reqMsg, Boolean bProxyCase)
at System.Runtime.Remoting.Proxies.RemotingProxy.Invoke(Object NotUsed, MessageData& msgData)
at System.Func1.EndInvoke(IAsyncResult result) at UiPath.Core.Activities.OCREngineActivity.EndExecute(AsyncCodeActivityContext context, IAsyncResult result) at System.Activities.AsyncCodeActivity1.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)


#2

#3

Thanks for help and actually Google OCR engine works fine for me. I just want to know the root cause why Microsoft OCR engine doesn’t work for me. Anyone has idea for the issue? Thanks.


#4

If you see properties of MicrosoftOCR or GoogleOCR engine you can find scale number. If you change that shows impact of results. By default GoogleOCR will use scaling number 2 where as scaling number in MicrosoftOCR would be 1. that’s the reason some times MicrosoftOCR will fail. try to change this number and see. It may work!


#5

I tried with scale number 1,2,3 but it doesn’t work. Anyone can help on this issue? Thanks.


#6

Even I am also facing same issues, could you please help!.