Microsoft OCR Engine not working

Hi all,

I’ve already read numerous posts on the Microsoft OCR Engine not working and what to do about it:



However, these don’t provide me an answer to my problem.

Microsoft OCR is installed on Studio and is available in the activities. But when I run the robot I get the following error:

The robot is running in a controlled test-environment and has therefore limited access to the outside world (hence: internet connection is limited).

Can it be that the OCR engine needs connection to some kind of external server? To my understanding Microsoft OCR is installed with the Studio and can therefore run locally…

I’ve removed Studio and installed it again, but still getting the same error.

Strange thing is that I’ve also run the same scrip in a more ‘open environment’ and there it is working fine.

I’ve read that missing software (MODI) could be the issue, but also that in newer Studio versions it’s not needed anymore… Besides that the MODI software is not available anymore (Microsoft has removed it).

Something is not working but I can’t get my head around the problem… all help is welcome, thanks!

Im am not sure if it needs internet to work, only that is something provided by Microsoft and while there is the activity in UiPath, the support for it may be limited, see more info here:


And try other options if you cant use it…

@bcorrea, thanks for your reply!
Unfortunately the UiPath docs don’t give any information on this… :frowning:

Other options don’t work for me because they are not stable and accurate enough