Microsoft 365 package : Impossible to use v2


I have a problem using the Microsoft 365 package: I cannot install version 2.x.x, only version 1.

Windows compatibility seems to be a problem because I can install v2 of the package only with a Windows Legacy project.

Studio : 22.4.4 Enterprise

I do not know how to use v2 package ?


Hi @marc.loppion

Try to update UiPath.System.Activities to lastest version.

The package description says you need Studio 23.10+ version to use Office 365 package from version 2.3.3 or above


Hello @ rikulsilva

When I try to update UiPath.System.Activities, the same error appears.

For the Microsoft 365 package, i try to update version 2.2.7 which seems to be good with my version of Studio.


Hi @marc.loppion

Yes, the studio version required is 21.10+ for this Office 365 version. It will works fine.

If you have a specifc case to use the lastest version try to update your studio


1 Like

Hi rikulsilva

Unfortunately, I can’t decide what is the version I can use, this is my enterprise…
One solution would be to change the compatibility of the project ( Windows → Windows - Legacy). However, I don’t know how to do that. (business process was already implemented)


It doesn’t cost anything to upgrade, and if you’re on that old of a version you are on an unsupported version. This should make it clear to your organization that it’s long past time to upgrade.

Update studio solved the problem.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.