May i know how to resolve it?


Try to use workbook activity

Install the Microsoft office in the machine after that use Excel application scope in it.


Showing us how you use your excel application scope would definately help.

First the 'have you tried turning it off and on again"-troubleshoot:

  • is the file a proper excelfile (not a renamed csv for example)?
  • Can you manually open it?
  • try opening it, saving it, and closing it, and then try your sequence again.
  • Does your workflow work if you use a different excelfile? (e.g. is the error in your code or in your file?)

thank u for the response


I hope you are using the Excel scope activity. Here as per the error there is an issue with the excel application, can you go to Home->Tools->Microsoft repairing tool

Try to repair it, mostly it will resolve if there is any glitch.

Microsoft Office Issues(Studio%20Backstage%20View,The%20repair%20tool%20opens.&text=A%20tab%20for%20each%20Microsoft,Office%202013%20and%20newer%20versions.

I tried all ways but still not solved my error

@SHAIK_MOHAMMAD Can you try killing excel before the excel scope using Kill Process activity

tried but still it is an error

what i have to enter in process and process name?

plz share the screenshot of the full workflow

ProcessName is “EXCEL”. kill the process and try again.

Here, beofre to excel applications cope use Kill Process activity,In properties write Process Name - “EXCEL”.

Then try to execute.

@SHAIK_MOHAMMAD Refer to the below thread on how to kill excel, Using Kill Process activity, In properties write Process Name - “EXCEL”


  • Search for Kill Process activity in the activities panel


  • Give the Process Name as EXCEL


  • Keep this activity before excel scope. Run the process and check the results

@SHAIK_MOHAMMAD Try using Workbook activities instead of excel scope