MAXCC=0000 message not getting displayed sometimes in mainframe Terminal Session

Hi All ,
I am currently using terminal session and its terminal activities for mainframe automation purposes.
According to usecase requirements, I need to submit a job. When i execute the SUB command,then “JOB SUBMITTED***” is displayed on screen. Once this is displayed I need to click on Enter again so that the MAXCC=0000 message will be displayed ( This MAXCC message is a proof that job was submitted without any errors).

Sometimes on clicking enter- this MAXCC message is displayed.But sometimes, this MAXCC is not displayed. Why is this so? Manually in mainframe, always this message gets displayed, but using terminal activities -on clicking enter, Sometimes it works as expected but sometimes I am redirected back to the previous page instead of this message.

Could you please help me that why is this so unreliable? I added various logics like Delay before pressing enter, but facing the same issue sometimes.

Could you please help me with it.

Thanks a lot!


  1. Try checking if any other key stroke also works to move to the next screen
  2. Is the enter being clicked once only?
  3. Check if the transistion is happening without wnter also and ehen enter is sent the next screen is coming up


@Anil_G Thanks for the response.

  1. No we do not have any other key stroke. We need to click “enter” only.
    2.Yes, enter is clicked only once. On clicking enter once, sometimes, its getting redirected to next screen with MAXCC message & sometimes, its getting redirected to previous screen.
    3.The transition only happens once enter is executed. Without enter, nothing happens.

So this issue occurs sometimes only, but it should not occur because manually when i work in mainframe always the message is getting displayed.


Are you using send control key activity only?

And sending trasmit option?


@Anil_G Yes I am using Send Control Key activity with transmit option.


Try with send keys and send [enter]


@Anil_G Yes i did that- First I used Send Keys activity with “enter”. And then below that I placed send Control Key with “Transmit”. So now, it is first typing the word enter and then clicking on enter.


As of now, i checked running the bot one time, this method is working successfully as the MAXCC is getting displayed. But i need to run the bot multiple times and see if its reliable.

Hope it works all for all runs! This method i didn’t try earlier and i think this should work for all runs.

Thanks a lot! :slightly_smiling_face:

1 Like


enter to be enclosed in square brackets to consider it as a key…then you might not need transmit as well…but check however it is reliable for your case

Hope it works. happy Automation


Hi @Anil_G , Thanks for solution , but still even after using send keys , Sometimes it is getting redirected to the previous screen. I have tried all possible ways like adding delays,etc. After trying all ways, I am unable to find a solution for it, & I think it seems to be some issue with the Terminal session emulator in the UiPath itself because of which this glitch is happening.

@loginerror Could you please help me with this issue? Why sometimes after submitting the job and after clicking enter, it is coming back to the previous screen instead of moving to next screen having MAXCC message. It happens rarely but this shouldn’t happen since its not reliable then.

Thanks a lot ! :slightly_smiling_face:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.