Manage Packages Download System.Data.DataSetExtensions and it's failing

Hello all
Trying to install the [System.Data.DataSetExtensions] through the manage packages within UIPath Studio and I get a package installation error.

Any ideas…


Hi @bananas911

Could you post a screenshot of the error or paste the full error message in here? Also, which version of UiPath Studio are you using?

Information below

Here is a screen shot of being able to pull down a dependency (X.509) successfully but failing on another (Linq)…Red circle just says package installation failure. If there is a commonality both of the failures are Linq related, but not sure if that’s an issue…?!?

I asked around and the issue comes from the fact that it is simply not a package that is available in UiPath feed :slight_smile:

All you will have to do is to google for the particular package and then put it in a local feed. This can either be:

or any folder you want, if you add the path to in as a feed in your Package manager settings (you can read more about it in our documentation).

Hello Maciej

Please find attached the errors. I have attached the screen shots. I am using a 60 day license version of UIPath…-> Studio 2018.4.1 - 12/12/2018 Enterprise Edition Windows Installer Expires in 11 weeks License Provider: External Device ID: +CvtO2D/iKWipBkkjyZB

Microsoft Windows 10 Enterprise 64-bit .NET Framework Version 4.7.1

I even downloaded nuget.exe pulled down the package added it locally and pointed the package manager to it, “local.jpg” still no success. I have been able to successfully download other MS packages (System.Net.Http), just not 100% why this one is having an issue however another MS package is having issues as well, error2.jpg shows another MS package with issues. If its anything these 2 packages have in common, they both are Linq packages.


(Attachment error log.txt is missing)

This is really tricky, as the packages are not developed by us.

It might be that some dependencies are missing.

1 Like

sigghhhh !!!

I can’t be the only one with this problem. Are you (loginerror) able to download these packages to your instance of UIPath ??

1 Like

Hi @bananas911

I believe making this package to be installed correctly from package manager is not being currently considered.
(EDIT. It was since then confirmed that not all packages from feed are compatible as a direct dependency)

However, given that Studio has changed tremendously in the past year, it is possible that you can now achieve your original goal without installing it.

Could you provide more context behind your original idea you wanted to pursue at the time? We might find a seeming workaround with on the latest 2019.9.0 version :slight_smile:

I had the same problem installing that nuget, which I wanted because the video I was watch regarding Joining 2 tables and extracting all mismatches using the following assign was not working without it.

In my situation I used the Join Table and it produced the results I wanted.

I’m not sure this helpsyou, but I thought I would mention it.


After reading Maciej’s note, regarding “Some dependencies are missing”, it made me think to check for a later version. And I found the following.

I uninstalled the original and installed Version19.12.0 preview, and this made the error for “AsEnumerable” not part of “System.Data.DataTable” disappear, which was my issue.

I also located a note in at the end of the video I was watching.

When I checked my xaml file that reference was added as a result of using the latest version. So, it appears UIPath solved the problem. Hope it helps.

Good Luck!

Thanks Maciej for pointing me in the right direction.

1 Like