"LogMessage" Activity Missing even though UiPath.Core.Activities nupkg listed as "Installed" in Package Manager

Hello there,

Using UiPath Studio V 2017.1.

I transferred my workflow from my local machine towards a virtual machine.

Some activities were missing and other were deprecated (Excel , UiPath.web etc.) on the VM Studio so I tried a risky solution of copying my C:\Program Files (x86)\UiPath Platform\Packages folder from my local machine to the same folder on the VM

The current result is the UiPath Studio on my VM not even having “log message” as an activity.

I tried :

  • Restarting Studio, Restarting Robot Service
  • Going through package manager and trying to uninstall reinstall all packages
    (No new packages can be found)
  • Deleting all activities from %localappdata%\temp and C:\Program Files (x86)\UiPath Platform\Packages on the VM then restarting UiPath Studio
  • Executing the process from Robot Tray while Packages and Temp was clean of any nupkg
  • Copying everything from my temp/nuget folder from my local pc to my VM.

What I don’t understand is that I’m missing basic activities such as LogMessage or MessageBox or Comment.

I think that those activities are linked to UiPath.Core.Activities nupkg, and I have version UiPath.Core.Activities.17.1.6522.13190

This nupkg is present in the Studio Package Manager as Installed and I still am missing a lot of the core activities for the Studio

Any help would be greatly appreciated.



May I know why you are using old version of studio ?

Why can’t use latest version of studio.

Hello @lakshman

Client context. Upgrading to new version is not a viable solution for now.

Problem solved by :

Deleting all the activities in C:\Program Files (x86)\UiPath Platform\Packages
Deleting all the activities in %LocalAppData%\temp\Nuget
Deleting all the activities in %localAppData%\UiPath\Activities
Deleting all the activities in %localappdata%\UiPath.cache
Restarting the machine
Launching process from Robot Tray

Orchestrator must of downloaded the proper activities in order to allow to package to work.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.