Library Activity compilation problem (Couldn't create it in RPA dev advanced)


I’m creating a library in Uipath Studio. I have created some new files and I’m trying to publish a new version, but I’m getting an error while compiling that says : “Unable to create activity builder for document. Reason was ‘missing key value on Bachelor object.’.”

The only activity with ‘Bachelor’ in it is an ‘Invoke Workflow File’ that calls a file called “Bachelor.xaml” which has no arguments
Below is a screenshot of the Workflow file that doesn’t compile :


Any help is appreciated.

Thanks in advance

1 Like


Welcome to the uipath community.

Could you please run the workflow in debug mode and help me with the screenshot of that error. So that we can help you better in this.

Hi, did you test this as a normal Process before creating it as a Library project?

@bcorrea Hello, yes I did test it as a normal process. I tried removing the first invoke to see if the library will compile, but it gives the same error for all the other invoke workflow in the other cases of the switch activity

@lakshman Hello, thank you for answering. How can I debug the compilation of the library ?

1 Like

@lakshman @bcorrea I have tried to re-create all the files in cas they were corrupted. I left only one invoke file in the switch activity and succeeded in compiling the library. But the moment I add another invoke workflow file in another case statement, the compilation errors with the same error mentioned in the post.

1 Like

I managed to solve the issue by adding an enveloping sequence to all the invoke files inside each case in the switch activity. I don’t know why it works this way and not the other way. It clearly has something to do with wpf and xaml syntax


Maybe it is a bug, that could be check by UiPath if you can open a ticket. Good that it is solved tho!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.