Level 3, Assignment 1 (Security Hash) - Data Scraping not producing Data Table

Hi there,

My first question here so apologies if not in right format or any other issue. I tried to look through solution but couldn’t find it. I am stuck on this 1st assignment (security hash).

  1. My sequence workflow for HTML data extraction via data scrapping doesn’t seem to be work. When I run that workflow, the screen doesn’t move (screenshot attached). I am not getting error as such. Is there an easy way to look at whether it managed to extract data table as required (I tried message box but it comes up blank). I am also attaching xaml file if that helps.
    Extract Data Table.xaml (6.9 KB)

  2. I am not able to figure out how to extract client info (name, ID, country). The instructions dont share much details. I managed to look at some videos but when I run it, it simply doesnt produce right values from the page (as I tried using message box at the end).
    System1_ExtractClientInformation.xaml (9.2 KB)

Any pointers or help will be greatly appreciated.


1 Like

Thanks a lot @AndyMenon. This helped. The main issue was that it wasn’t picking up “Next page” UI element exactly in the center on internet explorer. It did on chrome though.

Now, I am stuck on follow up problems and trying for hours. The data extracted doesnt have column headers. I cant figure out why. Please see screenshots of data scraping wizard (it does pick up there) but when I extract data on excel, it doesn’t.

Please also see xaml file just in case I may be doing anything wrong. I played around already a lot with this but headers are not coming. I believe this is whats stopping to move things forward because there is a reference of column header in my other workflow and it wont proceed if headers aint coming in.

Test Extract Data2.xaml (7.6 KB)

Your help will be greatly appreciated.


Plesae ignore the question above @AndyMenon. I was simply looking at wrong place to tick on “Add Headers”. I found it now and its extracting data properly.

Not sure why project is not picking up work item IDs when running but I will try to take a look at that now.

By any chance, can you look at my 2nd point just in case you may be able to share some insights.

Thanks again for your help.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.