Level 3 Assignment 1 Error: Option Strict on disallows implicit conversions from string to integer

I am trying to debug the first assignment in the level 3 training, but I keep getting the “disallows implicit conversions from string to integer” error in the import arguments for the navigate to work item page workflow. I have the value inputted exactly how they show in the walkthrough guide. Also a little confused as to how to try to fix this because it says from string TO integer, but I aim trying to go to a string and if anything its FROM integer to string.

I’ve tried to go in and separate the input arguments into just the system1 URL and the Work Item ID, but am getting the same error. Any help is appreciated!

check your arguments from that workflow, its probably because of the in_WIID_URL argument from ur workflow is integer.


Thanks for the reply. My arguments in the workflow are all of the string type. Any other guess what it might be?

can you screenshot the argument panel of that “navigate to WorkItem Details”? coz as far as i’m able to tell, that error only occurs when ur variable types are mismatched

Here is my arguments inside my work flow.

I split the original argument into 2 as a way to try and see what’s wrong. The transactionItem part was giving me this same error when I used “WIID” in the parenthesis. but it did get rid of the error when I just indexed the transactionItem datarow. I just am confused why the other wouldn’t work is it is supposed to be calling the same data.

Here’s the updated argument input:

Forgot the add the other picture but here is the values for the arguments

did the error disappeared? :joy:

yea it did. not really sure what I did but thanks for trying to help!