Kill the application

Hi All,
I just want to kill the application and I used get process and then pass for each after that I applied kill process but I get error (“Index was outside the bound of array”).

In kill process , I used-system.diagnostics.process.getprocessbyname(“Internet Explorer”)(0)

Please help…

Hey @Nidhi2,

Little correction here:


are you trying to kill the internet explorer ? then try this …
send hot key win+r and then send this
in type into activity
“taskkill /f /t /im iexplore.exe[k(enter)]”

thanks @amarasto for your help .
but still showing same error.
Pls help…

thanks @kalyanDev.
I am trying to close my application (CMO) which is running on Explorer.
still showing same error.
Pls help…

First you need to check whether the process is running or not if it is running then kill the process.

IF (system.diagnostics.process.getprocessbyname(“Iexplorer”).Length>0)

hey @amarasto.
It doesnot stop the process.

Hey @Nidhi2,

Please find the workflow attached.

_Test.xaml (11.1 KB)

please find the below workflow . This kills current session of the applications listed in the string array . KillProcessesFromCurrentSession.xaml (14.3 KB)

1 Like

thanks @Uthraa
Now its working fine.
thanks a lot…

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.