Keying value into AS400

Background on my robot: I’m trying to do a loop through a bunch of lines of excel, using the “Excel For Each Row” activity, and copying an order number and pasting it into an AS400 system(we call it Steeb).

My issue: For some reason I’m not able to actually paste the order number into the AS400 system. I’ve been able to play through the Keyboard shortcuts that i’ve recorded, but the order number never appears. I’ve tried using the “Type Into” activity, where I type this: “CurrentRow.ByField(“APO06”)” into the area where I think I’m trying to enter the data. I wonder if the issue is marking the target in AS400…I had to manually select the area around where The data is supposed to go, and maybe i’m not selecting it properly. Any help would be greatly appreciated!

I hope I understood your question right and you do face issues with typing in values into the host.

for host applications we do use the terminal activities e.g. set field, set field at position offered from the UiPath.Terminal.Activities package (via Dependency Manager)

Thank you so much ppr! how do I go about getting the terminal activities package? I don’t see a “dependency Manager option” when i move around UIPath StudioX. Thanks again!

ensure go / official chanel is enabled. if not enabled do it via the gear / settings

Thank you, ppr! I just added that package. Now i can add the “set field” and “set Field at Position” activity. I’m not familiar with how to use those activities though. Right now I have a keyboard shortcut to hit tab a few times to move the cursor to the field that I want to put the order number in. I was hoping that those activities would be straightforward, but they both ask for multiple input values(when I’m really just wanting to paste one value). What are the differences between these fields?

Also, I eventually get an error that says, “Terminal Error: NotConnected”. How do I connect the terminal?

Thanks again for your help!

HI ppr, I don’t know how to install the Go! channel. I’ve tried googling, but I can only pull up information from the enterprise version that doesn’t seem to match. Can you assist?