I’m getting this error while running my workflow first it indicates that UiPath Robot Executor stopped and then it throws this error
RemoteException wrapping System.Exception: Job-stopped-with-an-unexpected-exit-code-0x000000FF.

Try to restart the UiPath robot from services

Hope this helps


Check at which step it is throwing this error, if it stopped at any while loop. Please put 2 seconds delay inside the loop and test it again. @PrabhuViswa


Hi I have the same error , and I have tried to restart the Robot , but I am not seeing any robot services, and there is no loop in the program also , and I amgetting this error only while executing the Excel programs.

@palak_sawhney where you able to solve this issue?

Yes , my issue has been solved , excel was not compatible with uipath , so I installed other version.

Can you please share the versions(Uipath, excel and excel activities) that worked for you.

I am using the following
UiPath: 20.4.1-beta.22
Excel 2007
excel.activities: 2.8.5, I tried downgrading this, but then I got following error.

Could not find type ‘UiPath.Excel.Activities.Business.SequenceX’ in assembly ‘UiPath.Excel.Activities’. Row: 62, Column: 4

I am using the same version of Uipath , and for excel 2013 , 2016 and 365 are compatible with uipath. You can use either of them. And excel activities are already integrated in uipath.

Thanks @palak_sawhney. Excel 2007 is not supported by Uipath, need to update my office.
Thanks for the help and quick response.