JIT compilation is disabled for non-Legacy projects

Hi ,

The UiPath studio has been updated to Studio 2022.12.0-beta.11471 - 12/20/2022 Community License as of yesterday.

When I run the bot after that, I get this exception; however, if I run the bot in debug mode, nothing happens, and this problem only affects one bot, not all of them.

System exception at initialization: JIT compilation is disabled for non-Legacy projects. ExpressionToCompile { Code = "System.Activities.InArgument1[System.String]", ImportedNamespaces = System.Collections.Generic.HashSet1[System.String], VariableTypeGetter = System.Func`2[System.String,System.Type], LambdaReturnType = System.Object } should have been compiled by the Studio Compiler. at Source: UiPath.Executor.Core

Please assist in resolving this



Hi @Doneparthi_Chaitanya

To resolve this issue, you will need to update the UiPath runtime to the version that matches your UiPath Studio version. You can do this by going to the “UiPath” menu in Studio, selecting “About,” and then clicking the “Check for Updates” button. This should download and install the correct version of the runtime for your project.

If you are still encountering issues after updating the runtime, you may want to try the following:

  1. Restart your machine and try running the project again.
  2. Check the UiPath logs for any additional error messages or clues about what might be causing the issue. The logs are usually located in the %LOCALAPPDATA%\UiPath\Logs folder.
  3. Try repairing the UiPath installation by going to the Control Panel, selecting “Programs and Features,” selecting UiPath, and clicking the “Repair” button.
  4. If the issue persists, you may need to uninstall and reinstall UiPath. Make sure to back up any custom assets or project files before uninstalling.


1 Like

Hi @Doneparthi_Chaitanya
Did @Kaviyarasu_N advice resolve the issue?

Hi ,

I have tried all of the suggested solutions, but the problem persists.

I was contacted by another RPA developer about this issue in a chat earlier, and it was resolved by updating the dependent libraries. It may be a little different from your event.


For me, updating the UiPath.System.Activities to latest version helped resolve the issue which was occurring only at runtime (not while debugging)

Hope this helps!


Hi Amit,

Thank you so much. The issue got resolved after updating System Activities to latest version.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.