Java Applet window Autmation

studio

#1

Does anyone had done to automate objects on Java Applet window? I am straggling with them but the selector doesn’t recognize them. Only window itself can be recognized.


#2

Check this thread


#3

vvaidya, thank you for your quick reply!
I had already checked this QA, installed Java extension and re-tried, but it didn’t changed anything.
So you mean UiPath cannot recognize Java Applet with Selectors? To resolve this matter, only I can do is to use Citrix image functuion, is it correct?

Regards…


#4

@Thiago might be able to answer this question since he was working on some government java based app few weeks back.


#5

Thank you! I will contact him!


#6

Hello @NatsuOK

I had a similar problem with a Java Application, but I wasn’t able to solve it.
It seems that some applications don´t enable Java Active Accessibility, and this limits UIPath to navigate the app UI elements.

If you have enough time to investigate deeper, and somehow find a solution to this, please share with us. The related thread above can give you some tools for it.

For my case (I had already spent 3+ days trying to solve it), I changed strategy to Citrix automation :rolling_eyes:


#7

UiPath works with java applets as long as the java extension is properly installed and the applet exposes Java Active Accessibility.

See also: UiPath and Java

Adrian.


#8

Thank you Thiago, Adrian,

Today I had a meeting with UiPath member and discussed about this issue. His thought is that in this moment UiPath cannot correctly install Java extension. They are going to fix this install function, so we might want to wait until this minor change is published.

I will use Citrix image function instead of using selector.

If I said something wrong, please correct my words!


#9

Hello, am new to UiPath. Had similar issue with a Java applet screen. Without admin rights to our customer furnished PC where UiPath is installed, we cannot install Java extension. But I tried recorder for Citrix, Image/Mouse/Click and that worked for my UI automation.


#10

Hi,

I’m facing a weird issue while working in a java applet called ERP application. Sometimes the application is being recognized as an image while sometimes different elements are being recognized. However there is some issue with selectors. I’m trying to perform operation like click, get text etc. and everytime i’m getting the issue of selector not found. Can anyone help me on this.