Issues with Calculator automation exercise in Windows 10

Hi, just downloaded UIStudio Community Edition and am running it on a Windows 10 virtual machine.

I’m finding a lot of troubles trying to replicate the Calc.exe automation demo. For example, there is no “Copy to clipboard” menu entry on the Calculator application. I’m afraid the W10 Calc version has changed a lot from the W8 version.

Has anyone successfully run that example?

Known issue. Metro is not yet supported.

Thanks for the fast response. Is there any resource where I can check these compatibility or supported environments? I didn’t find it mentioned in the forums.

This is not the entire list, however…

List of supported OOTB:
UI Frameworks
*Web (Chrome, Internet Explorer, Firefox)
*Windows Forms
*Java (Swing, AWT, SWT)
*FoxPro, MS Access
*Adobe Reader
*Mainframe emulators (Attachmate Reflection, Rocket BlueZone, IBM Personal Communications, IBM EHLL Standard)

LOB Apps
*SAP GUI(with or without SAP scripting enabled)

  • Oracle Apps
  • Siebel
  • Peoplesoft
  • Sharepoint
  • Microsoft Dynamics
  • Salesforce
  • NHS Electronic Staff Record

Integrations at the API level


  • VB expressions, .Net framework
  • SQL (MSSQLServer, Oracle, MySQL, Postgress, MS Access)
  • LINQ (for in memory data)
  • XML & XSLT
  • JSON
1 Like

tried UiPath on Client’s VB system, UiPath did not work at all. Is there extra plugin i need to install? @badita

What do you mean by that?

And how did not work? We need more details. Have you installed the .exe or the .msi?

Hi ovi, thanks for the reply.

I installed latest UiPath CE version, but UiPath Explorer can not identify the Ui element of the logon window. but this works on notepad.exe. This morning , after i restart the system and uipath, it works. Amazing …

thanks agian.

1 Like

Hi, I’m just trying to do the same Calculator exercise on Community edition with Win10. is this metro still not supported yet?

thanks in advance.

It is, what studio version are you using?

Hey Gabriel.

Even on this very day I am facing the same issue. Trying to run the sample calculator recording and cannot do anything beyond pressing start button.

Version (community edition) at my machine is 2018.2.0.