Issue with UiPath.Database.Activities with Windows 10

Hi, I have built a bot on a Windows 8 machine and I have started testing on a Windows 10 virtual machine. I’m using the UiPath.Database.Activities package and it’s failing on the Win 10 machine.

To test I have a Connect activity and using the Connection wizard with the same data source and file name on both machines I get the following results:

Windows 8:
image

Windows 10:
image

I’m using the latest version UiPath.Database.Activities = 1.2.6863.32528 and the database is located on a server that both machines have permissions to. I’ve used the full path so it’s not a mapping issue.

Any advice would be much appreciated.

Thanks :slight_smile:

Since it gives you error outside uipath, it is not an error made by the uipath.database.activities.

Possible Reason:

  1. You’re attempting to open a database file that’s created in a new version of Access with an older version
  2. You don’t have the latest services pack for MS Access installed
  3. The MS Access database file has been corrupted.

Possible solution:

  1. Try using the Compact and Repair Database option

source: How to Fix Microsoft Access Unrecognized Database Format Error

2 Likes

Thanks for your reply.

I worked out that I needed to install the Microsoft Database Engine - Download Microsoft Access Database Engine 2016 Redistributable from Official Microsoft Download Center

After installing this I get a new error, so I’m a bit further along!
image
I have raised a ticket with IT but if anyone knows what I should try I’m all ears :ear::ear:

1 Like

Hi @charlie.wood,

Great…! Welcome back to Forum buddy…!

Kindly refer to this link for this issue,

https://www.layer2solutions.com/support/business-data-list-connector-faqs/how-to-access-office-2010-data-from-sharepoint

May be it can guide your IT Team as well,

Hope this would help you

Cheers…!

Thanks :+1:

I had installed the components mentioned in that article and wasn’t having any luck.

I tested my connection using a udl file which I found info about here - https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000PADkSAO&l=en-GB

The test results pass so everything is good on the machine but it’s still not working in UiPath Studio.
I have a meeting with IT today to see if it’s group policy settings but would be interesting to see if anyone is able to replicate this in UiPath Studio.

With help from UiPath support, all I needed to do was install Microsoft Access 2010 Runtime 32 bit

Hopefully this will help someone one day.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.