Issue with filter datatable

Hi guys,

I want to filter a data table based on a value of a column,
I wrote:
“ColumntName”<“10”
but id didn^t work.
Any Idea how to deal with Integers in this filter?

Thanks in advnace

Use dataTable1.select("[Column1]<10")

is it not possible to use filter data table acitivity?

You can use the same activity. I just tried and is working fine.

Remove the double quotes in column filter value and try.

“ColumnName”<10

Also if your numbers are not in stored as integer or double in the table this might not work

Try it now

Process - Copy.xaml (10.7 KB)

still the same it shows nothing

You need to provide the Output Columns which you require in Output Datatable.

image

no it’s not mandatory, since I wamted to keep all columns.
but I tried it anyway


and I have nothing, the filter doesn’t work.

I checked it. No output. “WIID” column is considered as String. So we need to convert it to Int32 before we filter. We dont have that functionality in Filter DataTable. But Select statement can do it.

dataTable1.select(“Convert([WIID],system.int32)<10 AND [Status]=‘Open’”)

2 Likes

hello Vivek,

Is that a data table ? or I have to add at the end .CopyToDataTable?

This will give you Array of Rows as output. You can use .CopyToDatatable to convert to Datatable

Itired this : ExtractDataTable.select(“Convert([WIID],system.int32)<10 AND [Status]=‘Open’”).CopyToDataTable
but it says cannot find column [‘Open’] any Idea?

Can you send the screenshot of your select statement. It seems like you have given [‘open’] instead of [Status]

yes that was it, thank you so much for your help :slight_smile: I apreciate it

1 Like

Great…:grinning:

Please mark the solution as Solved