Issue with Filter Data Table activity

datatable
activities
bug

#1

Filter Data Table activity seems not working properly with UiPath.Excel.Activities update or something.
Filtering early achievers among 300 employees (lesson 9 part 2 in UiPath Academy level 1) worked fine before, but now after the update, it only shows column names.
I guess Issue with filter datatable posting reports same issue.


#2

Hi @kimrew
If filter data table activity is not working then you can use with assign activity
Steps
1.use build data table activity to create column names
2.create a data row variable with assign activity = dt.select("‘column name1=value and column2 name=value’")


#3

Hi @kimrew
Check this post for your reference
Filter Data Table Column Field
Thanks
Ashwin.S


#4

Select keep option in output column tab. And also mention the column to be included in output Datatable.

Also, ensure that your condition is satisfied in filter rows tab.

image


#6

Yes, it worked fine that way, but it is not working anymore after something updated.
Same file from Academy download link, same activity with same condition.

image


#7

Please show the screen shot of output column tab as well. If possible send the Workflow.


#8

Hi, I got the same probem with the Filter Data Table activity. I tried all options but no luck :thinking:

This is the screenshot of the downloaded main.xaml. It doesn’t recognize the filter data table activity.


#9

I have the exact same issue as above.


#10

Hi @llind

Could you post a screenshot from your Package Manager, like this:

Could you try updating/repairing your packages via this manager?


#11

Hi, I updated the packages I have and tried again with no luck. I do notice that you have a higher version of UiPath.System.Activities than I do. I do not see how to get the alpha version of this. Please advise.

Here is what I have:


#12

I don’t think there is a problem with this particular activity pack, but you can get it by clicking the Include Prerelease box at the top:
image

There is a pre-release Excel activity pack that you might give a try.

If all else fails, please go to the:
%userprofile%\.nuget\packages and rename the folder packages topackagesBackup`.

This will force Studio to redownload all the packages upon restart and hopefully fix your issue.


#13

Hi,

Using the Prerelease check box does not show any pre-release packs for the ones we are talking about above. I have also renamed the packages folder and restarted Studio. This reloaded new packages and I still cannot get the Filter Data Table activity to work correctly. It doesn’t seem to be filtering anything. It reads the excel file and outputs the data in the excel file in a message box with no filtering. This is what I have: