Issue : Method not found : "Void Mimekit.Paramter.set_encodingMethod"

#1

Capture

I have provided the below details for the SMTP send email
Port : 465/587(tried both)
server : “smtp.gmail.com
Logon Email : "gxxxxxx@gmail.com"
Logon Password : “xxxxx”

Kindly help to sort of this exception.

#2

Hello,
Looks like there is old version of dll resides in the system.
make sure to update the mail package from package manager if available
also check the .net framework version in the machine. (install kb update according to your OS)
minimum 4.5.2

#3

HI,

My system is with the latest updates.

  1. .NET Framework 4.6.1
  2. KB890830
  3. Mail Package is latest i have verified from the package manager.

Kindly let me know if anymore prerequisites need to check.Thanks in advance.

1 Like
#4

Hi,

I had the same issue today (after updating to to 2018.1.4) where mail activities was latest version but kept getting that error.

What I found was that MimeKit version was 1.2.7.0 and an update was available ( you need to uncheck Filter Activities).
After update to version 2.0.3.0 (which was latest available from Package Manager), the error stopped and SMTP send resumed working.

Good luck!

1 Like
Save Mail Message : Method not found: 'Void MimeKit.Parameter.set_EncodingMethod(MimeKit.ParameterEncodingMethod)'
#5

Hi,
I’m Facing the same error, Where the workflow runs completely fine on Windows7 RDC & This Error pops up while working on windows 10.

#6

I am facing the same error, but if I look at the updates on the packages from package manager I cannot found the 2.0.3.0 version. Any help?

#7

Uninstall current version in package manager and try install the version available! Try doing this couple of times by restarting the PC if it doesn’t work.

#8

I saw this issue yesterday with 2018.1.4 and I have been using this version from so long but SMTP was working fine. Yesterday randomly it just starting failing.
I tried all steps mentioned above and tried reinstalling packages from manage package atleast 5, 6 times and also restarted my system but error was still there. I did try reinstalling my studio as well but it also did not work.
The issue was actually resolved by clean installation.
I uninstalled current version and deleted all uipah folders and then installed the same version again i.e. 2018.1.4 which actually resolved my issue. Also in between so many times I restarted robot services and also after clean installation but not sure whether that is required or not. But clean installation to the same version did help.
The reason I could not upgrade to newer version was because new versions giving me issues which I already have ticket raised with UIpath.

#9

I just hit this today running 2018.1.4. Has anyone determined why it happens and what the fix is?

Update:

Here’s what worked for me: I removed MailKit/MimeKit from package manager and rebooted. When the machine came back up I checked C:\Program Files (x86)\UiPath\Studio\Packages the packages were still there so I deleted them. Then I started studio and was able to use the activity App Integration–>Mail–>SMTP–>Send SMTP Mail Message

This doesn’t seem intuitive and i can’t explain why it worked but that’s what I did.