Getting MailKit Version 1.18.0.0 could not load error using smtp.gmail.com

uiautomation
studio

#1

Hi All,
I’m trying to send emails via smtp.gmail.com, how ever I keep getting this error message before even the Send SMTP Message activity is processed:

Send SMTP Gmail Message has thrown an exception

Source: Send SMTP Mail Message

Message: Could not load file or assembly ‘MailKit, Version=1.18.0.0, Culture=neutral, PublicKeyToken=4e064fe7c44a8f1b’ or one of its dependencies. The system cannot find the file specified.

Exception Type: FileNotFoundException

System.IO.FileNotFoundException: Could not load file or assembly ‘MailKit, Version=1.18.0.0, Culture=neutral, PublicKeyToken=4e064fe7c44a8f1b’ or one of its dependencies. The system cannot find the file specified.
File name: ‘MailKit, Version=1.18.0.0, Culture=neutral, PublicKeyToken=4e064fe7c44a8f1b’
at UiPath.Mail.Activities.SendMailActivity.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

Any advice is appreciated.
Fpayan


#2

Hi Fpayan. I had the same issue and was able to resolve it by closing UiPath Studio, deleting the workflow’s associated project.json file, and reopening Studio.

In case that doesn’t work, try checking that your Host settings in the Properties panel for the SMTP Send Mail activity match these:
Port: 587
Server: “smtp.gmail.com