Issue in using Excel activities - Namespace issue

Hi all,

I am trying to read an excel file and getting the below error.

Current Microsoft office version : 2016

Tried running the same code in different machine it runs fine without issues.

Saw this namespace error showing up as in below, can this be the cause? If yes how to resolve this…someone please me on this.

Already tried upgrading and downgrading the excel packages and also tried adding the namespaces like interop excel and few other namespaces in the import namespace option in uipath studio, nothing worked.

@Palaniyappan @vvaidya @GreenTea

Hi @Raju23c

Did you try to run the repair tool?

I also faced the same issue, used a Kill Process activity with “excel” as process name before the excel scope. It worked for me. Give it a try.

Thanks for your response @kumar.varun2

I tried doing that, but it’s not working.


While running the project is there any microsoft office application also running? e.g., outlook

Yes, but I have tried running after closing all the Microsoft instances like teams and outlook, then also it didn’t work.


Try by setting cache instance period to 0 in excel scope and also use kill process before excel scope.