Issue in uninstalling UI Path Studio

Hi Everyone,

I wanted to uninstall the UiPath Studio, but while processing I’m getting below error:
Service ‘UiPath Update Service’ (UiPath.UPdateService) could not be stopped. Verify that you have sufficient privileges to stop system services.

Even though services are stopped in Task Manager, still I’m getting this error.
Can anyone please suggest what could be the reason behind this error?


Hello @karan.aggarwal1

Could you refresh the services and checked whether it auto started.

Are you using the personal machine?? And do you have the privileges to uninstall the apps?

Hi @Rahul_Unnikrishnan , I tried refreshing it but it did not start.

I’m using corporate machine, but tried using Admin privileges too, still studio won’t get uninstalled.


Can you check in Task scheduler whether any jobs are running. If yes plz stop it and try for an uninstallation.

  • Unattended Robot: UiPath.UpdateService.Worker.exe is installed as Windows Service and UiPath.UpdateService.Agent.exe is not installed.
  • Attended Robot: UiPath.UpdateService.Worker.exe is installed as Windows Service; UiPath.UpdateService.Agent.exe is installed as LogOn Task in Task Scheduler.
  • Quick Install (user mode): UiPath.UpdateService.Worker.exe and UiPath.UpdateService.Agent.exe are installed as LogOn Tasks in Task Scheduler.
1 Like

I’ve these two services ready in Task Scheduler

  • UiPath RobotJS

  • UiPath Upgrade Service Agent
    Both of them triggers “At log on of any user”

@karan.aggarwal can you try to disable ?

Hi @Rahul_Unnikrishnan , I disabled the two services and uninstalled the UiPath studio.
But even after uninstallation “%programdata%\UiPath” folder is not getting deleted, it says already in use and can not be deleted.

@karan.aggarwal1 Once you uninstall the studio make sure you remove all the folders related to it. Reboot the server and try installing it again

@ushu I’m trying to remove the above folder, but it is not getting deleted even with Admin rights. It says “folder in use”, services and temp files are already deleted.

@karan.aggarwal1 That’s fine . Reboot the server and try to install the studio again

@karan.aggarwal1 if you want to remove the folder do as below.

Start>>All Programs>>Accessories>>System Tools>>Resource Monitor (or Run resmon.exe )

You can search for the “Associated Handles” using the searchbox (circled in red), and right click the process you want to end.