Issue in excel application scope activity- Error opening workbook. If Excel is installed, run the ‘Repair Tool for Microsoft Office Interop’ from the Tools tab on the Home screen

Hello,

Getting this error in excel application scope activity when running the BOT in unattended mode on VM. It is working when we are running the code in attended mode with UiPath assistant.
Have tried running the repair tool for office multiple times as the error message says but no luck.

Please let me know for any suggestions on above issue.

Thanks in advance.

Is Excel installed on the VM? Same version?

You mentioned you have run it attended, did you run it on the VM attended and using the same robot account as it runs under when unattended? If so make sure you SIGN OUT. Don’t just close the RDP window, that leaves the session open and interferes with unattended automations.

If you’ve logged into the VM with the same account as the robot, then log in again but this time SIGN OUT from the start menu. Then run your unattended job.

Hi,

Thanks for the reply.

I did sign out from the VM with Bot credentials which we are using in unattended mode. It works with Bot credentials in attended mode with UiPath assistant.

Microsoft office professional is installed on the VM which includes excel application.

Can you elaborate what do you mean by same version of excel ? compared to ?

I thought you are running it attended on a different machine, like your computer during development.

You clicked Start then Sign Out, right?

You don’t need Assistant (nor Studio) installed on servers that run unattended automations, but it doesn’t hurt anything.

I bet when you installed everything you selected user mode. Re-run the UiPath installer and select Service mode.

Hi,

I have installed the robot in unattended mode and as per the uipath documentation service mode gets selected automatically by that way. I think there is no option to select user/service mode in 2022.4 setup(It was there in 2021 versions)-