Internal Error - How?

When I open my .xaml, I always face with this error:


Attached are the logs:
Errors.xlsx (9.1 KB)

When I click on validate, there are no validation errors, hence I do not know what is causing this. Please help. Thank you.

Please refer the below link.

1 Like

@Vivek_Arunagiri thanks i have tried but it does not resolve my issues

If have any decisions or conditions check them by opening all of them individually, sometimes errors in decisions are not visible in workflow level

@Divyashreem thanks. I have checked every single code but there is no error…

Or is there any way that I can pinpoint all these errors? As the log is not showing at which line are all these errors at.

Hi guys, any help on how to resolve the issue would be very much appreciated…

Hi Edmundz - As per the logs which you have provided,even i have faced this problem.
I have created two variables, where one variable uses the other variable at initialization[which has no value yet]. And when i ran the workflow i also received error mentioned in the excel : System.NullReferenceException: Object reference not set to an instance of an object.
But i have not faced the issue mentioned in the screenshot yet.
Could you please check if there is any object thats being referenced by other object.

I also faced the same issue but once i restart the main program in UiPath Studio the problem got resolved.
This error comes usually when you are working on some file which you downloaded from the net. Try to save the file in correct path under program file in UiPath where all Uiprograms are saved, then your problem will be solved.

Is there a proper way to restart the main program? Cause I open and close Uipath the same error still keeps popping out. However there was once I used a dependency which was saved under a local drive, and I deleted it as I was able to get it online. Is there a way to check if it’s the depencies which is causing the issue?

Have you saved the dependency also in Uipath folder under program files where all Uipath programs are saved.But i don’t think if there a way to check if it’s the dependencies which is causing the issue

at that point of time i didn’t save it with other uipath programs.

Then save it also under uipath folder i think when the main program get all dependency under one folder only then problem will be saved.

1 Like

I’m having the same problem, every time I open my main file. The problem has exitsted since I updated my UiPath Studio

Could you maybe attach a sample workflow that causes the error?
Also, which version of Studio do you use?

It’s a quite large workflow that I’m developing for my company, and therefore can’t upload. If I delete huge chuncks of the file, the error disappears. I’m gussing that it has something to do with dependencies. When I update all the dependencies, most of the library activities disappears and the file is unable to save or execute.

The version is: 2018.3.1

You could try to use the Copy to Clipboard option and paste here the result. It might give us some clues.

I am getting this.

An internal error has occurred. It is recommended to restart UiPath Studio.

Error: System.ArgumentException: Illegal characters in path.
at System.IO.Path.CheckInvalidPathChars(String path, Boolean checkAdditional)
at System.IO.Path.InternalGetDirectoryName(String path)
at UiPath.Core.Activities.Design.InvokeWorkflowInteractiveDesigner.GetWorkflowFullPath()
at UiPath.Core.Activities.Design.InvokeWorkflowInteractiveDesigner.SetProperties(Object sender, RoutedEventArgs e)
at System.Windows.RoutedEventHandlerInfo.InvokeHandler(Object target, RoutedEventArgs routedEventArgs)
at System.Windows.EventRoute.InvokeHandlersImpl(Object source, RoutedEventArgs args, Boolean reRaised)
at System.Windows.UIElement.RaiseEventImpl(DependencyObject sender, RoutedEventArgs args)
at System.Windows.UIElement.RaiseEvent(RoutedEventArgs e)
at System.Windows.BroadcastEventHelper.BroadcastEvent(DependencyObject root, RoutedEvent routedEvent)
at System.Windows.BroadcastEventHelper.BroadcastLoadedEvent(Object root)
at MS.Internal.LoadedOrUnloadedOperation.DoWork()
at System.Windows.Media.MediaContext.FireLoadedPendingCallbacks()
at System.Windows.Media.MediaContext.FireInvokeOnRenderCallbacks()
at System.Windows.Media.MediaContext.RenderMessageHandlerCore(Object resizedCompositionTarget)
at System.Windows.Media.MediaContext.RenderMessageHandler(Object resizedCompositionTarget)
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler), HResult -2147024809

Can you post a screenshot of the workflow where this is occurring?