Installing Packages when starting Bot

Hello everybody,

every time I start a robot on the orchestrator, the Information Shows, that the Maschine is installing packages.

I have already tried the issue to delete the Project.json file, but this doesn’t work for me. (Solution found here)
There is no new json file created when starting the main.xaml in Studio.

Is there another way to fix this issue?

Greets
Yannik

1 Like

Hi @em17,
Which version of Studio and Orchestrator do you have?

1 Like

Hi Pablito,

Studio Version 2018.2.3
Orchestrator 2018.4.4

Greets

1 Like

Please check if you Studio/Robot installation forder is not protected from saving (read only).

1 Like

The folder is protected (read only). Is it necessary that you can do changes in the folder?
Some time ago there was no “installing packages” even though the folder was protected.

1 Like

The folder is protected by default, but your user account needs to have proper rights to this folder.
image

2 Likes

If anybody is struggling with the issue of robot ‘installing package’ or failures due to ‘Cannot create unknown type’, this is what helped me. Check that you have a reference to a local activity feed in the Nuget.config file in the following locations:

C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\NuGet
C:\Program Files (x86)\UiPath\Studio.
C:\Users%userprofile%\AppData\Roaming\NuGet
Keep at least one feed active, if local feed is not present, add it, like so

3 Likes

Hi, could you please provide a more detailed path of the folder? I also have similar issue that my task keeps running for 15 min or so with the same info message ‘installing package’ and then fails with the time out error. I tried to run another package on the same machine and it works… super confusing to me. Could you please help me a bit? Thank you