Installing package

@ovi @badita @aksh1yadav I have implemented a workflow in production. Each time when I execute the process on the bot, it takes some time to install the package even if there are no changes in workflow. Why is it installing each time, if it has been already deployed in that bot. Is there any way to avoid that step and directly start job processing.

Hi @VKL

Do you execute it from Robot tray or Orchestrator?

Did you publish it locally or in Orchestrator?

Also, if it’s published and ran from Orchestrator, I’m not sure I understand what do you mean by installing the package before running the job. Can you please give more details? And Orchestrator version.

I tried both options tray and Orchestrator. It is taking some time to install the package before starting the job. I use UiPath Studio 2018.2.3 Enterprise, not sure where to check version of Orchestrator. Eg. When I start the job PROC1_PRODUCTION which already executed for many times. Please see the Info

  • Process: PROC1
  • Environment: Production
  • Robot: User2
  • Info: “Installing package…”
  • Start Time: 2018/08/29 9:29:59
  • End Time:

It took around 3 minutes to start the job

  • Process: PROC1
  • Environment: Production
  • Robot: User2
  • Info: “Job started processing”
  • Start Time: 2018/08/29 9:29:59
  • End Time:

Hi,

i got the same Problem. Is there allready a fix to this Issue?

BUMP

@Anthony what Studio, Robot version? Does the problem persist?

I I have the same problem I’m using version 2018.4.1
also acitivites don’t seem to be installed on robot… When I execute process it even can’t open a browser
Cannot create unknown type ‘{http://schemas.uipath.com/workflow/activities}OpenBrowser’

I checked %LocalAppData%\UiPath\Activities folder does not exist . I think it may be the cause of the problem

Hi @ygulas

Could you zip your project and share it with us?

Hi Maciej

I found a solution and found the root cause. After disabling myget.org and nuget.org robot was able to download the activities from orchestrator. Maybe it would be nice to put a note on robot package installation that if robot does not have connection to internet before publishing nuget.org and myget.org should be unchecked at development studio

Regards ,

Yalcin

Where did you disable ?

Studio -> Manage Packages -> Settings

@ovi UiPath Studio 2018.2.3 Enterprise and same for Orchestrator. I will test the solution from ygulas and share my result later.

In my Studio Version( 2018.2.3) is no menu item for Settings. Pic related.

Is there another way to disable it? Maybe a settings file?

Hi @Anthony

I guess in this case you should see here for the guide for the 2018.2 version:

Hey @loginerror, was thinking if you know if a solution is available for 2018.4.4? The “Auto Update” option is no longer available for this. While running the process from Ui Robot, the “installing packages” part is taking a really long time. No Orchestrator is involved, just the Enterprise Studio and Robot.

Hi All,

Has anyone found solution for this issue?

Hi @Gyan

What exactly is your issue? If the packages take long time to get downloaded upon install, please see this solution posted a bit up in this thread:

Actually I have upgraded UIPath from 2018.1 to 2018.4.3 and after that every time when the process is running, its downloading the packages.
I found the similar thread 2018.4.4 UI Robot Tray keeps prompting installing packages
I tried the solution posted but still it didnt work :frowning:
Could you please let me know if you have the solution for this.

Hi All,

I somehow managed to resolve the issue.
I was facing the issue due to the project.json file as it was created by the older version of the UIPath.

What I did was , I first deleted the project.json file and then opened the MAin.xaml from Studio whuch by default created a new project.json file and once this file was created , I published the code and run the job from orchestrator/Robot Tray, and I did nt receive any issue of “installing packages” this time.
Please let me know if it resolves your issue .:slight_smile:

Regards
Gyan

1 Like