Insights installation - 'Http failure response for https://example.com/analytics/SisenseCustomTableThreshold/GetTableCountInfo: 400 OK'

I’m trying to install Insights on-prem. I’m using Orchestrator 20.10.6 with Insights 20.10.0

Install went OK but when I navigate to the Insights tab in the orchestrator GUI i get the following error: “Http failure response for https://example.com/analytics/SisenseCustomTableThreshold/GetTableCountInfo: 400 OK”

I made sure that the insights link (https://insights-url.com/app/account/login#/login) properly loads into a chrome browser in the Orchestrator VM and is not giving certificate errors.

I cheked that the SQL user i used has db_owner privileges over the Insights database, which is the case, so that’s ruled out too.

I do notice, however, that when I Navigate in Server Management Studio to the Insights database, no new tables where created after installation, which seems odd:
image

I tried re-enabling Insights from the UiPath.InsightsAdminTool in the Insights VM, and the process gets completed but sends a “Could not setup tenant” message:
image

I tried re-enabling Insights using the admin tool through the command prompt; but it’s giving me “invalid object name” errors for a couple of what I assume are non-existing tables:
image

I navigated to the url contained in the error message and getting the following error: **{“message”:"Failure on Insights DB query ",“errorCode”:3007,“resourceIds”:null} **

Most probably it’s a problem with the Insights Database; I would like to try building the database schema manually, as the installer doesn’t seem to be doing the trick.

Does anyone know how to go about creating this schema / have another suggestion? I’m kind of stuck and would appreciate any input.